Install KDE 4.4.3 on Kubuntu 10.04

5 May

The KDE Developers today announced the release of KDE SC 4.4.3. With the immediate release of KDE 4.4.3 is the possibility of upgrading your Kubuntu 10.04 installation from KDE 4.4.2 to KDE 4.4.3, which is recommended by the KDE developers, since 4.4.3 is a bug translation update.

To upgrade your Kubuntu 10.04 Installation you must first add the following PPA source:
ppa:kubuntu-ppa/ppa

You can do this using kpackagekit, which can be found in your launcher menu:

In KPackageKit go to Settings –> Edit Software Sources

While in the Software Sources window click on the Other Software tab then click Add

You’ll see the following source added.

Now you use KPackageKit to upgrade your machine as you normally would (the 4.4.3 updates will be listed under Updates and not Bugs). This is done by going to Software Updates, clicking Select all updates and then Apply.

ben.kevan

I am ben kevan.. Well yeah. .that's about it.

9 thoughts on “Install KDE 4.4.3 on Kubuntu 10.04

  1. The upgrade fails. There is an unependency not being met. Kde package kdelibs5 is requiered to be at least 4.4.3a but only the version 4.4.3 is available. Probably is only in some europeans mirrors… KDE does not boot at the moment…

  2. Arg… I used aptitude to fudge partial updates and now I’ve remove a chunk of my KDE install.

    *sigh*

    The update’s definitely broken.

    What’s the ppa for the beta ppa?

  3. Here are the packages that were upgraded for me, per /var/log/apt/history.log:

    ksystemlog (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa2), plasma-dataengines-workspace (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), krdc (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), krfb (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), kdebase-plasma (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), kppp (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), kdepim-runtime (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), libprocessui4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libtaskmanager4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kdebase-workspace (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libkscreensaver5 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libsolidcontrolifaces4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), printer-applet (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), libkwineffects1 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), ksnapshot (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), libkipi7 (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), kdepim-groupware (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), oxygen-icon-theme (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), kdebase-runtime (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), linux-image-generic (2.6.32.21.22, 2.6.32.22.23), libkleo4 (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), plasma-widgets-workspace (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), konqueror-nsplugins (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), kdebase-data (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), gwenview (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), kdelibs5 (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), okular-extra-backends (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), linux-image-generic-pae (2.6.32.21.22, 2.6.32.22.23), kcalc (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), plasma-dataengines-addons (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), klipper (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libmimelib4 (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), kdemultimedia-kio-plugins (4.4.2-0ubuntu3, 4.4.3-0ubuntu1~ppa1), kontact (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), ksysguard (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libkexiv2-8 (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), libplasma-geolocation-interface4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kde-l10n-engb (4.4.2-0ubuntu6, 4.4.3-0ubuntu1~lucid1~ppa1), libkcddb4 (4.4.2-0ubuntu3, 4.4.3-0ubuntu1~ppa1), plasma-widget-kimpanel-backend-ibus (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), dolphin (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), kde-zeroconf (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), konsole (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), korganizer (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), libkonqsidebarplugin4 (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), libksgrd4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kamera (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), ark (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), libkpgp4 (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), kdebase-workspace-bin (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libkworkspace4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libkonq5 (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), kdelibs5-data (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), libkdepim4 (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), libkdecorations4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libksieve4 (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), libplasmagenericshell4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kfind (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), kdebase-bin (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), systemsettings (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libkfontinst4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kdm (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), knotes (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), plasma-widget-kimpanel (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), kaddressbook (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), libkephal4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), plasma-widgets-addons (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), libplasma3 (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), kdebase-workspace-data (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), ksysguardd (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libplasmaclock4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kdepimlibs5 (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), libweather-ion4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kdebase-workspace-kgreet-plugins (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kdelibs-bin (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), libsolidcontrol4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), linux-generic-pae (2.6.32.21.22, 2.6.32.22.23), khelpcenter4 (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), libkonq5-templates (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), plasma-desktop (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kdegraphics-strigi-plugins (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), libksignalplotter4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kwalletmanager (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), ktimetracker (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), kdepim-strigi-plugins (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), plasma-widget-folderview (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), libokularcore1 (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), kate (4.4.2-0ubuntu3, 4.4.3-0ubuntu1~ppa1), plasma-scriptengine-javascript (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), libplasma-applet-system-monitor4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), linux-headers-generic-pae (2.6.32.21.22, 2.6.32.22.23), plasma-scriptengine-python (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), libprocesscore4 (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), kdebase-runtime-data (4.4.2-0ubuntu4, 4.4.3-0ubuntu1~ppa1), kde-window-manager (4.4.2-0ubuntu14, 4.4.3-0ubuntu1~ppa2), linux-generic (2.6.32.21.22, 2.6.32.22.23), system-config-printer-kde (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa2), dragonplayer (4.4.2-0ubuntu3, 4.4.3-0ubuntu1~ppa1), kdepimlibs-data (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), okular (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), kmousetool (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), kmag (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), libkdcraw8 (4.4.2-0ubuntu1, 4.4.3-0ubuntu1~ppa1), kdepim-kresources (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), kdepim-wizards (4.4.2-0ubuntu5, 4.4.3-0ubuntu1~ppa1), python-kde4 (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa2), oxygen-icon-theme-complete (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), kdepasswd (4.4.2-0ubuntu2, 4.4.3-0ubuntu1~ppa1), kmix (4.4.2-0ubuntu3, 4.4.3-0ubuntu1~ppa1)

    Maybe they are in the midsts of rebuilding? It worked fine for me on a clean installation of 10.04.

  4. I made the update on 2 computers yesterday, on first one it went ok, on the second one not so much. I had the same problem with unmet dependency as Kubunteando and it removed some of my kde packages like konqueror…

    And the news article from kubuntu.org is gone now, also…

  5. Pingback: Links 7/5/2010: RHEL and CentOS 3 EoL, Fedora 13 Near | Techrights

Leave a Reply

Your email address will not be published. Required fields are marked *