Installing google-drive-ocamlfuse on openSUSE 13.1

17 Dec

A few people have emailed and asked about google-drive-ocamlfuse on openSUSE 13.1. Although I’ave been extremely busy lately, I felt that it was worth a shot, and a report on progress.

I’ve successfully built opam and then google-drive-ocamlfuse on my openSUSE 13.1 system. Here’s what I had to do:
Install the following repository:
http://download.opensuse.org/repositories/home:/eclipseagent:/opam/openSUSE_13.1/

After installing the repository, install the required applications with zypper:

sudo zypper in opam ocaml-findlib gcc ncurses-devel ocaml-ocamldoc libcurl-devel sqlite3-devel ocaml-camlp4-devel fuse-devel zlib-devel

I just did that out of memory as I forgot exactly everything that was needed, but I believe that was it.

After installing the above then run:

opam init

Selecting “y” when asked to import into bashrc etc.

Lastly run:

opam install google-drive-ocamlfuse

Now you have google-drive-ocamlfuse which you can setup by doing google-drive-ocamlfuse /local/mount/point

google-drive-ocamlfuse has some limitations, you can read more about them @ the .

Thank you, enjoy.

ben.kevan

I am ben kevan.. Well yeah. .that's about it.

5 thoughts on “Installing google-drive-ocamlfuse on openSUSE 13.1

  1. i have some Problems with this.

    System Opensuse 13.1 64 bit.

    with

    opam install google-drive-ocamlfuse

    i get errors:

    =-=-= Installing ocamlfind.1.4.0 =-=-=
    ocamlfind.1.4.0 Downloading http://pkgs.fedoraproject.org/lookaside/extras/ocaml-findlib/findlib-1.4.tar.gz/5d1f8238c53964fdd14387b87b48b5d9/findlib-1.4.tar.gz
    Copying ~/.opam/repo/default/packages//ocamlfind/ocamlfind.1.4.0/files/ocamlfind.install to ~/.opam/system/build/ocamlfind.1.4.0/
    Building ocamlfind.1.4.0:
    ./configure -bindir /root/.opam/system/bin -sitelib /root/.opam/system/lib -mandir /root/.opam/system/man -config /root/.opam/system/lib/findlib.conf -no-topfind
    make all
    make opt
    make install
    [ERROR] The compilation of ocamlfind.1.4.0 failed.
    Removing ocamlfind.1.4.0.

    what can i do?

  2. I can’t succeed to install google-drive-ocamlfuse

    I installed opam (from http://download.opensuse.org/reposit…openSUSE_13.1/), and these packages: ocaml ocaml-runtime ocaml-compiler-libs ocaml-findlib ocaml-ocamldoc ocaml-camlp4 ocaml-camlp4-devel gcc make m4 ncurses-devel libcurl-devel sqlite3-devel fuse-devel zlib-devel tack libulockmgr1.

    Than I gave these commands (as root):
    opam init
    opam update
    opam install google-drive-ocamlfuse

    Unfortunately I get:

    =-=-= Installing camlidl.1.05 =-=-=
    Applying cpp-location.diff.

    [ERROR] Due to some errors while processing camlidl.1.05, the following actions will NOT proceed:
    – install ocamlfuse.2.7.1-cvs2
    – install google-drive-ocamlfuse.0.5.3

    ===== ERROR while installing camlidl.1.05 =====
    Could not get the source for camlidl.1.05.
    ‘opam install google-drive-ocamlfuse’ failed.

    Any ideas?
    Anybody succeed? (openSUSE 13.1 64bit).

    Thanks in advance for any suggestion.

Leave a Reply

Your email address will not be published. Required fields are marked *