Using Juniper VPN on 64-bit openSUSE Linux 13.1

28 Aug

Currently we’re upgrading our juniper VPN which brings the Network Connect version from 6.x to 8.x. Although this doesn’t provide direct support for 64-bit java, it does bring better support for 64-bit java.

I was able to get it running for the most part using the Juniper KB25230 however, for OpenSUSE they only indicated that you had to install:

zypper install libXi.so.6

This is not the case. I also had to install the following:

zypper in libXrender1-32bit libXtst6-32bit

while using KDE.

I was able to determine that by the following errors whilst launching:

Exception in thread “main” java.lang.UnsatisfiedLinkError: /opt/java32/jre1.7.0_67/lib/i386/xawt/libmawt.so: libXrender.so.1: cannot open shared object file: No such file or directory

and

Exception in thread “main” java.lang.UnsatisfiedLinkError: /opt/java32/jre1.7.0_67/lib/i386/xawt/libmawt.so: libXtst.so.6: cannot open shared object file: No such file or directory

This is a much nicer and cleaner solution than the one I previously had to use on Network Connect 6.0 (or pre 7.3).

Now I just hope Juniper will do their part and provide a Junos Pulse client for Linux.

ben.kevan

I am ben kevan.. Well yeah. .that's about it.

One thought on “Using Juniper VPN on 64-bit openSUSE Linux 13.1

  1. Pingback: Using juniper network connection VPN on openSUSE 12.2 x86_64 | Free Techie Blog

Leave a Reply

Your email address will not be published. Required fields are marked *